Skip to content
20 - 04 - 2009 / Gómez Hyuuga

Instalar drivers ATI en Fedora 10.

El día de ayer me dispuse a instalar Fedora 11 en esta computadora, lamentablemente me daba un error al final de la instalación de que no podía montar la partición para “/”. Traz una serie de intentos e intentos no conseguí hacerlo :-(. Bueno el caso es que hasta llegué a borrar la partición de Fedora 10 e intentar instalar F11 en ella pero como dije, no tuve ningún éxito.

Al final de todo tuve que reinstalar Fedora 10, al volver a instalar todas mis cosas que tenía antes, me llevo a recordar un artículo que leí en el blog rm -rf / acerca de que el driver 9.4 de ATI que ya tiene tiempo que salio mejoraba la compatibilidad para ciertas distros Linux.

Me volví a animar a intentar instalar los drivers para mi tarjeta ATI desde el binario que proporciona la web oficial (cosa que nunca había logrado hacer ya que me arruinaba el xorg y mejor los instalaba desde el repo RPM Fusion) pero bueno, fui optimista y lo intenté. Vaya sorpresa que me lleve de que al fin pude hacerlos funcionar :-).

Bueno basta de rollo. Explicaré cómo los instalé desde el binario y cómo instalarlos desde los repositorios de RPM Fusion.

Nota: Puede que a algunos no les funcione el driver, todo dependiendo de su tarjeta gráfica. Ha habido casos en los que ha funcionado perfectamente.

Importante: Al instalar los drivers desde cualquier método puede que si haz hecho algo mal o los drivers no son compatibles o lo que sea que salga mal, tu configuración del entorno gráfico quede estropeado, como bien dije, explicaré cómo yo los instale así que si no te funciona intentaré ayudar al que pueda pero no me hago totalmente responsable de cualquier daño que ocurra (eso va para que luego no lleguen comentarios diciendo que por mi culpa se les jodió su entorno gráfico :-P).


Método 1: RPM Fusion.

Primero explicaré cómo instalarlo desde los repositorios de RPM Fusion. A mi me iban bien, excepto por algunos detalles de que por ejemplo al cerrar sesión (no reiniciar) o al reiniciar las X se colgaba el sistema y marcaba un error en el kernel.

Si deseas instalarlo, primeramente deberás tener agregado el repositorio, después abre una terminal e introduce el siguiente comando:

su -c 'yum -y install akmod-fglrx'

Espera a que termine el proceso, después reinicia tu sistema y listo. Así de fácil así de sencillo ;-).

Actualización 26/04/09. Gracias a Webber por avisar que para los que tienen tarjetas ATI Radeon HD puede que les funcione este otro:

su -c 'yum -y install xorg-x11-drv-radeonhd'

Método 2: Binario v9.4.

Éste método es el que he instalado recientemente y todo me ha ido perfecto, incluso los cuelgues que se me daban al cerrar sesión o reiniciar las X ya no aparecen.

Para instalarlos, primero necesitaremos descargar el archivo binario de los drivers desde aquí. Seleccionando nuestro SO (Linux obviamente ya sea x86 o x86_64) y el modelo de tu tarjeta.

Una vez descargado abriremos una terminal e instalaremos antes algunos paquetes necesarios para la instalación:

su -c 'yum -y install kernel-devel kernel-headers libgcc gcc gcc-c++ zlib fontconfig freetype libstdc++'

Después navegamos al directorio donde descargamos el archivo, por ejemplo:

cd /home/usuario/Descargas

Ahora iniciamos el instalador como root con el siguiente comando:

su -c 'sh ati-driver-installer-9-4-x86.x86_64.run'

Veremos una ventana como esta:

Instalación de drivers propietarios ATI.

Instalación de drivers propietarios ATI.

Marcamos la opción Install Driver 8.602 on X.Org 7.4 and later releases y pulsamos el botón Continue.

Nos preguntará si aceptamos la licencia de uso, pulsamos en I Agree. Después nos aparecerá la siguiente ventana:

Instalación de drivers propietarios ATI.

Instalación de drivers propietarios ATI.

Marcamos la opción Automatic y pulsamos el botón Continue…. esperamos a que termine la instalación.

Cuando haya terminado desde la terminal abrimos el system-config-display como root para generar el xorg.conf, escribiendo el comando:

su -c 'system-config-display'

Si no lo tienes instalado lo puedes hacer con el siguiente comando:

su -c 'yum -y install system-config-display'

Una vez abierto no haremos absolutamente nada, solamente pulsamos el botón Aceptar y el programa se cerrará generando el xorg.conf.

Después escribimos lo siguiente en la terminal para configurar el xorg con el driver de ATI.

su -c 'aticonfig --initial -f'

Al hacerlo y que les haya mostrado de que se a introducido la configuración correcta ya podremos reiniciar nuestro sistema y difrutar de los drivers ;-).

Si el entorno gráfico ya no carga, restauraremos la configuración del entorno gráfico, iniciando en modo de consola de recuperación e introducir el comando:

su -c 'mv /etc/X11/xorg.conf.original-0 /etc/X11/xorg.conf'

Con eso puede que se arregle a como estaba antes.

Como dije, puede que a algunos les funcione únicamente el primer método o el segundo o inclusive ninguno, ya será cosa del modelo de su placa.

Anuncios

19 comentarios

Dejar un comentario
  1. iyanmv / Abr 21 2009 10:28 AM

    Muy buena entrada…. El problema es que a mi no me funciona nigno de estos metodos 😦
    SI lo instalo desde RPM Fusion = pantalla negra
    Si lo instalo desde el binario de la web de ATI = pantalla negra 😦

    PD: Tengo una ATI Radeon HD 2600, cual tienes tu?¿

    • Gómez Hyuuga / Abr 21 2009 1:08 PM

      Es una Raedeon 3100, a mi antes tampoco me funcionaban desde el binario pero con la versión 9.4 ya me funciona ;).

  2. israrace / Abr 21 2009 1:09 PM

    Iyán: exactamente igual que a mí: pantalla negra y no se puede salir con ninguna combinación de teclas. De todos modos voy a volver a intentar con esta nueva versión, a ver que tal.

    Saludos!!

    • Gómez Hyuuga / Abr 21 2009 1:26 PM

      Espero que si te funcione esta versión. La verdad yo no esperaba que me funcionara a mi XD pero si lo hizo :).

      Suerte!

  3. Israrace / Abr 21 2009 1:27 PM

    Por lo que parece, mi tarjeta no soporta el 9.4, solo el 9.3 porque ya la mandaron a la lista “Legacy”… mala suerte 😦

  4. israrace / Abr 22 2009 8:41 AM

    Nada, no funciona.

    • Gómez Hyuuga / Abr 22 2009 1:22 PM

      Zzzz! q mal 😦 espero que en futuras versiones ya funcione con tu tarjeta :). Suerte!

  5. webbber / Abr 23 2009 10:48 AM

    Los que tienen ATI radeon HD no han probado con:
    xorg-x11-drv-radeonhd
    A mi me ha funcionado

    • Gómez Hyuuga / Abr 23 2009 8:55 PM

      Si te funcionó con ese paquete? yo nunca lo había visto XDD. Todo va bien, no da problemas?

  6. webbber / Abr 25 2009 10:02 AM

    Pues a mi me funcionado bien, no infalible tampoco!!! pero me ha funcionado mejor que otros

    • Gómez Hyuuga / Abr 25 2009 11:27 AM

      OK, gracias webber. Ahora mismo actualizo el post con el paquete de ese driver :).

  7. Jorge / May 24 2009 1:42 PM

    emm.. aver baiscamente cague mi entorno grafico jajajaja… emm.. aver si me guias para recueprarlo que no me deja.. hice la segunda fomra que describes y ia todos los pasos bien (supuestamente) reinicie y .. muerte… no partio el entorno grafico..y en consola. puse lo ultimo que escribirste lo de (para la posibilidad de recuperarlo en caso se que no funcionara y se queda en > y nada mas… ) se te ocurre algo como para que me puedas guiar? mas que nada pa reestablecer o quitar el driver que s e instalo o algo asi Xd… vale…

    • Gómez Hyuuga / May 24 2009 1:49 PM

      Cierto, lo siento mucho, lo último que dices que se queda en > es porque falta una comilla al final del comando:
      su -c 'mv /etc/X11/xorg.conf.original-0 /etc/X11/xorg.conf'

      Ya lo he corregido, intenta a poner eso haber si te recupera el entorno gráfico.
      Otra cosa… estas en Fedora 10 u 11?

  8. Arkangel / May 25 2009 2:16 AM

    La verdad es que Ati en Linux es un poco putada, yo me pille Nvidia despues de intentar que funcionaran los drivers de Ati en el PC de un amigo, cuando cambie de ordenador.

    Era un reto interesante peeeero… xD

    • Gómez Hyuuga / May 25 2009 2:45 PM

      Tienes razón pero esos de ATI que no quieren dar más soporte, yo ya llevo varias semanas sin aceleración gráfica en Fedora 11 todo por la tarjeta ATI :(… espero que los de ATI den más soporte para Linux y así nos facilitarían más las cosas a todos.

      Un saludo y gracias por comentar 😀

  9. Avs / May 27 2009 6:06 AM

    Pues a mi una vez hecho todo y cuando solo me queda poner su -c ‘aticonfig –initial -f’ , me dice:

    aticonfig: NO supported adapters detected

    será que el driver 9.4 no soporta mi tarjeta? Tengo una ati radeon 9600, por si las moscas.

    • Gómez Hyuuga / May 27 2009 3:25 PM

      Lo siento Avs, tu tarjeta ATI Radeon 9600 fue movida a Legacy lo que quiere decir que ya no le darán soporte a ella.

      Link

      Como indica la página anterior, el driver 9.3 si serviría para tu tarjeta. Puede que con los mismos pasos del post se instale correctamente el driver, sino intenta con los de RPM Fusion haber que tal :).

  10. julio / Jul 7 2009 8:20 PM

    muy buena web
    mi pregunta es : tengo un notebook toshiba satellite a215
    viene con una ati radeon x1200 tengo fedora 11, me servira este tutorial para tener una buena aceleracion grafica?
    porque tengo los efectos del cubo y todo , aunque se pega aveces y pestañea la pantalla. me pasa lo mismo con ubuntu 9.04, pero en ubuntu 8.10 me andaba mas desente con los drivers de ati ,fedora 10 sera como ubuntu 8.10 o me equivoco?
    espero que me respondan
    gracias

    • Gómez Hyuuga / Jul 8 2009 1:53 PM

      En Fedora 11 no serviría, aún no se puede instalar el driver privativo de ATI :(…. será cosa de esperar.

      Y en cuanto a tu pregunta pues Fedora 10 tiene similares paquetes a Ubuntu 8.10 así que se definiría en aplicaciones como Ubuntu 8.10.

Comparte tu opinión

Introduce tus datos o haz clic en un icono para iniciar sesión:

Logo de WordPress.com

Estás comentando usando tu cuenta de WordPress.com. Cerrar sesión / Cambiar )

Imagen de Twitter

Estás comentando usando tu cuenta de Twitter. Cerrar sesión / Cambiar )

Foto de Facebook

Estás comentando usando tu cuenta de Facebook. Cerrar sesión / Cambiar )

Google+ photo

Estás comentando usando tu cuenta de Google+. Cerrar sesión / Cambiar )

Conectando a %s