Skip to content
16 - 01 - 2012 / Gómez Hyuuga

Instalar drivers Catalyst para tarjetas gráficas ATI

ati_logo

En esta entrada explicaré cómo pueden instalar los drivers gráficos propietarios en Fedora 16 para aquellos que disponen de una tarjeta gráfica ATI.

1. Asegúrate que tu tarjeta es compatible

Dirígete a esta página, selecciona el modelo de tu tarjeta, el sistema operativo (Linux x86/x86_64) y, si te permite descargar las últimas versiones (11.xx a la fecha), entonces probablemente puedas instalar el driver sin problemas.

Si solo te muestra la descarga del driver en su versión 8.xx o más antiguas, entonces lo más seguro es que no vaya a funcionar ya que no es compatible con las últimas versiones del Xorg.

2. Descarga el instalador

Una vez asegurado que tu tarjeta gráfica es compatible con los últimos drivers, entonces procede a descargar el instalador desde esa misma página.Al terminar la descarga deberías obtener un archivo de nombre ati-driver-installer-11-xx-x86.x86_64.run.

3. Preparación para la instalación

Antes de poder ejecutar el instalador, necesitas instalar ciertos paquetes para que el driver pueda ser correctamente compilado y anclado a los módulos del kernel.

Los paquetes son gcc-c++, kernel-headers y kernel-devel. Puedes instalarlos desde alguna herramienta gráfica o desde la terminal ejecutando:

sudo yum -y install gcc-c++ kernel-headers kernel-devel

Nota. Si utilizas el kernel-PAE sustituye el nombre kernel-* por kernel-PAE-*

4. Instalación del driver

Ya estás listo para continuar con la instalación🙂

Para ello necesitas ejecutar el archivo que descargaste anteriormente. Abre una terminal y navega hasta el directorio donde está el archivo. Por ejemplo:

cd ~/Descargas/

Y ejecuta el binario de la siguiente forma:

sudo sh ati-driver-installer-*-x86.x86_64.run

Puedes sustituir el asterisco por los números de la versión del driver o dejarlo como está, de todas formas funcionará.

Cuando inicie la ventana del instalador, selecciona la opción Install Driver x.xxx on X.Org x.x, pulsa en Continue y selecciona Automatic como modo de instalación.

Al terminar debería mostrar una ventana como esta:

5. Revisión de errores

Ya finalizó la instalación pero es importante que, antes de continuar, des un vistazo al log para corroborar que se instaló correctamente o si hubo algún error.

Abre el archivo /usr/share/ati/fglrx-install.log con algún editor de textos o ejecuta el siguiente comando desde la terminal para visualizar el archivo:

cat /usr/share/ati/fglrx-install.log

Si no ves ningún tipo de error (alguna frase en inglés que lo indique), entonces puedes seguir con el siguiente paso.

En caso de que encuentres algún error, no vayas a reiniciar el sistema ya que probablemente te quede la pantalla en negro y no puedas acceder al entorno gráfico. Si eso sucede, desinstala el driver ejecutando:

sudo sh /usr/share/ati/fglrx-uninstall

Reinicia y comparte el log de la instalación para ver si podemos ayudar en algo.

6. Ajustes finales

Por último hay que asegurarnos que el archivo de configuración del Xorg se configuró correctamente. Ejecuta lo siguiente desde la terminal:

sudo aticonfig --initial -f

Además, nos aseguraremos que el driver sea cargado junto con los otros módulos del kernel al inicio del sistema (gracias a length123linux por el tip). Ejecuta los siguientes comandos uno por uno:

su -
cd /boot
mv initramfs-`uname -r`.img initramfs-`uname -r`.img-original
dracut -v /boot/initramfs-`uname -r`.img `uname -r`

Y pues eso es todo. Ahora reinicia el sistema y todo debería estar funcionando correctamente😉

Nota. Hay otra forma de instalar los drivers y es mediante repositorios. En lo personal me ha dado varios problemas ese método pero si a ti te es más fiable, entonces puedes ver esta guía que indica cómo hacerlo.

99 comentarios

Dejar un comentario
  1. christopher / May 27 2010 11:11 PM

    No se como paso pero funciono, te segui todos los pasos al pie de la letra tal como sale en el post y me funciono la tarjeta ATI radion hd 5670 en fedora 12 x86_64 por fin puedo descansar en paz

  2. albert / May 29 2010 4:32 AM

    -tengo el siguiente error he puesto ********* para veais el mensaje debajo

    -ati gigabyte 5450 1gb ddr3

    -a parter de poder instalar me gustaria saber desinstalar para cuando salga la version 10.6

    -fedora 13
    ati-driver-installer-10-5-x86.x86_64.run

    ******************************************************************
    [root@linux Documentos]# su -c “sh ati-driver-installer-10-5-x86.x86_64.run”
    Created directory fglrx-install.gevgey
    Verifying archive integrity… All good.
    Uncompressing ATI Proprietary Linux Driver-8.732……………………………………………………………………………………………………………………………………………………………………………………………………………………………………………………………………………………………………………………………………………………………………………………………………………………………………………………………………………………………………………………………………………………………………………………………………………………………………………………………………………………………………………………………………………………………………………………………………………………
    ==================================================
    ATI Technologies Linux Driver Installer/Packager
    ==================================================
    which: no XFree86 in (/usr/kerberos/sbin:/usr/kerberos/bin:/usr/local/bin:/usr/bin:/bin:/usr/local/sbin:/usr/sbin:/sbin:/home/albert/bin)

    Error: ./default_policy.sh does not support version
    default:v2:x86_64:lib::none:2.6.33.4-95.fc13.x86_64:; make sure that the version is being
    correctly set by –iscurrentdistro

    Removing temporary directory: fglrx-install.gevgey
    ****************************************************************

    • Gómez Hyuuga / May 29 2010 2:45 PM

      Eso es porque en Fedora 13 no se pueden instalar, sólo en F12

  3. Freddy / May 29 2010 11:40 AM

    Excelente amigo ya lo instale muchas Felicidades por tu ayuda saludos!!

  4. Centra1C0re / Ago 20 2010 10:00 PM

    He detectado que los drivers graficos privativos tienen varios errores, me preguntaba si para desinstalarlo basta con ejecutar “/usr/share/ati/fglrx-uninstall.sh”???

  5. godklone / Sep 22 2010 9:54 AM

    problemas para instalar tarjeta de video ati 5770
    http://fpaste.org/p7KO/

  6. Camilo Segura / Oct 3 2010 12:42 PM

    Hola tuve un error al instalar el driver de la tarjeta ati hd-4250, esta es la que viene incorporada en la asus m4a88t-m. El enlace del error es http://fpaste.org/QJrR/

    Agradezco su auda.

  7. Luis tmbia / Oct 23 2010 9:54 PM

    1.
    [Message] Kernel Module : Trying to install a precompiled kernel module.
    2.
    [Message] Kernel Module : Precompiled kernel module version mismatched.
    3.
    [Error] Kernel Module : Kernel module build environment not found – please consult readme.
    4.
    [Reboot] Kernel Module : dracut

    Que debo hacer para corregir este error ?, gracias

  8. Hoka / Dic 17 2010 7:51 PM

    Hola, como verás me han dado las tantas intentando configurar la gráfica y todos los esfuerzos han sido en vano, he seguido al pie e la letra la guía que has elaborado y me he quedado en crear el xorg.conf con las opciones específicas de mi tarjeta. Llegado a este punto el terminal me dice: “aticonfig: No supported adapters detected”. Ahora mismo no sé por dónde seguir, si me pudieras echar un cable… te pego el log de la instalación por si te sirve de ayuda.

    http://fpaste.org/KJLh/

    Muchas gracia de antemano.
    Un saludo.

  9. German Jurado / Jun 15 2011 2:08 PM

    Tengo Fedora 13, y tengo una ATI Radeon 9550, pero no puedo configurarla y en este link parece el error del log. http://fpaste.org/0GjK/

  10. juan / Nov 15 2011 1:18 AM

    mi targeta es una amd radeon, es igual que una ati radeon????… funcionaran estos comandos???

    • Xibalba / Ene 17 2012 12:57 AM

      Asi es Juan, es lo mismo, pero cabe decir una cosa, los drivers propietarios de ATI no se llevan muy bien con Gnome Shell, asi que si eres usuario de el, personalmente te recomiendo los drivers libres ;D

      • Xibalba / Ene 17 2012 12:58 AM

        PD: No me fije en la fecha del comentario de arriba lol

        • Gómez Hyuuga / Ene 17 2012 2:50 PM

          xD muchas gracias por ayudar a la comunidad🙂
          Por cierto gracias por la info del bug del Live CD que me compartiste por G+

          Un saludo o/

      • Juan / Feb 25 2012 12:12 AM

        hermano… y como consigo los controladores libres???…

  11. Mario / Ene 18 2012 3:12 PM

    Antes que nada, muchas gracias por esta informacion, la verdad pense que nunca encontraria una explicacion para instalar correctamente los drivers propietarios de ATI xP

    Una pregunta, he leido que GNOME3 sufre problemas con estos drivers, y pues yo estoy usando Fedora 16 con este entorno de escritorio, que problemas me puedo encontrar si instalo los drivers?? Que me dan ganas pero tampoco quiero que me salga contraproducente hacerlo

    • Gómez Hyuuga / Ene 18 2012 4:39 PM

      Tengo entendido que Gnome-Shell no funciona con estos drivers (fglrx) aunque la verdad no he probado instalarlo y checar por mí mismo. Yo uso KDE y por lo menos ahí no me da nada de problemas.
      Como dice @Xibalba, lo mejor es que uses los drivers drivers Radeon aunque eso supongo perder muuucho rendimiento a comparación de los privativos😦

      • Mario / Ene 18 2012 8:17 PM

        mmm… okok, es que luego con los drivers libres la tarjera se calieta a mas no poder ): espereba que instalando los Radeon ya dejara de trabajar de manera innecesaria
        pero bueno, ya que este cercana la salida de Fedora 17 lo intentare, gracias

        • Xibalba / Ene 19 2012 1:47 AM

          Bueno, yo uso Fedora 16 con Gnome 3 en mi PC de escritorio, desde Fedora 15 los drivers propietarios de ATI han tenido problemas con Gnome Shell, ¿como cuales?, de los que me ha tocado sufrir es el ya clasico panel con color de arcoiris, relentización en el efecto de “exposición de ventanas” al mover el cursor y/o dar click a Actividades, aparte tambien una relentización al mover ventanas, es por eso que he usado los drivers libres, cabe destacar una cosa, este no es un fallo de Fedora, es un fallo nativo de los drivers, asi que para Fedora 17 si ATI no arregla eso en sus drivers, seguiremos igual.

  12. paran0id / Feb 1 2012 11:45 AM

    Buenas, he instalado los drivers y todo va bien, excepto que cuando voy a ver un vídeo KDE “crashea” y vuelve a la pantalla de login… también el plymouth ha dejado de funcionar:\

    ¿Alguna sugerencia? No he encontrado casi nada por internet acerca del problema.

    • Gómez Hyuuga / Feb 5 2012 8:08 PM

      Lo del Plymouth es normal, para corregirlo prueba a agregar la línea “gfxpayload=1024×768” al archivo /etc/default/grub.
      Acerca del problema con el vídeo no tengo ninguna pista, te pasa con todos los reproductores?

      • sigght / Feb 23 2012 8:59 AM

        He tratado de realizar lo del Plymouth, pero en /etc/default no tengo archivo grub.
        ???
        Respecto al otro problema, no importa que reproductor utilice sigue sucediendo.

        Gracias por el apoyo!!

      • sigght / Feb 23 2012 12:18 PM

        Cuando se cuelga me aparece el siguiente mensaje:
        “Failed to start LSB: Builds and install new akmod packages”
        en fondo negro, esto aparece de 2 a 4 segundos (tome una foto para apuntarlo jajaja) y luego me regresa a la pantalla de login…

    • sigght / Feb 23 2012 8:35 AM

      Me sucede exactamente lo mismo!!!

    • sigght / Feb 28 2012 1:05 AM

      Ya he encontrado una solución. Es la siguiente:

      Continué preguntando en otros foros hasta que llegue a http://ask.fedoraproject.org/, en la cual el usuario Malar me comentaba de la pagina http://ati.cchtml.com (pagina para reportar bugs en controladores propietarios de AMD no-oficial). Luego de otro tiempo de búsqueda encontré el bug 337, para el que tenga el mismo problema es http://ati.cchtml.com/show_bug.cgi?id=337 y tambien https://bugs.gentoo.org/391193. Al parecer xorg sufre un fallo fatal al reproducir un video utilizando la salida Xvideo, pero no utilizando cualquier otra salida de video, para solucionarlo es necesario cambiar la salida de video del programa utilizado y listo. En vlc es recomendable cambiarla a “Salida de video X11 (XBC)”, pueden encontrar la forma de hacerlo aqui http://www.esdebian.org/foro/48048/se-reinician-x-reproducir-video. Bueno y sin mas que decir… me despido deseándoles lo mejor!

  13. Rodrigo / Feb 13 2012 11:57 PM

    Holas!… cómo estas/n?!… yo de buen humor porque acabo de conseguir (al fin, luego de varios meses esperando) hacer andar los drivers privativos de AMD en Gnome-Shell!

    Cuento un poco mi experiencia porque tuve algunos problemas…

    Primero, luego de instalar los drivers, revise el log y tenía este error:
    “ERROR: Module radeon is in use
    Unloading drm module…
    ERROR: Module drm is in use by radeon,ttm,drm_kms_helper”

    Busque por google algunas solución y/o explicación y lo que encontré no me sirvió (o por lo menos no funcionó como en foros y blogs decían que iba a hacerlo)

    en fin, cansado de buscar (y confienso, con bastante sueño!) me dije: “que sea lo que tenga que ser”.. seguí los pasos que restaban de tu guía y reinicie el sistema…

    Con un nudo en la garganta espere que cargara el sistema y para mi sorpresa (y alivio) todo fue muy bien (salvo por el Plymouth que lo perdí).

    Pruebo como anda y los bugs que tenía antes (en las pruebas anteriores que había hecho hace meses) ya no estaban. Los menúes estan perfectos y no hay señales de la famosa barra arcoiris!

    El único problema que encontre fue que todas las ventanas y el sistema estaba muy lento (ese bug también estaba antes). Por suerte además de tu guía, antes de instalar había encontrado esto que guarde por si me hacía falta: http://www.taringa.net/posts/linux/13894236/Ati-Catalyst-y-Gnome-Shell.html

    Basicamente la “solución” esta en hacer un .profile en gedit con esta línea: “export CLUTTER_VBLANK=none “. Esto sirve solo para Gnome Shell hace un cambio en una librería que usa mutter… y voilá! reinicio y todo anda genial… sin arcoiris, los menúes se visualizan bien y todo el sistema tan fluido como antes.

    Todavía no consigo hacer volver el Plymouth (probé tu solución y otras que encontré en los foros de Fedora pero nada)

    En fin eso quedará para otro día, por ahora disfruto poder usar los dichosos driver’s de AMD/ATI

    Saludos y gracias!!

    Rod.

    p/d: perdón por la biblia que acabo de dejar! jaja

    • Gómez Hyuuga / Feb 18 2012 4:43 PM

      Genial que te haya servido🙂 Entonces GNOME Shell te funciona bien con los drivers?

      Un saludo y gracias por tu comentario (Y)

  14. manoloss / Feb 18 2012 1:25 AM

    hola amigo mira baje la version 12.1 y me marcaba un error

    amd-driver-installer-12-1-x86.x86_64.run: línea 415: ./ati-installer.sh: Permiso denegado
    Removing temporary directory: fglrx-install.EoqGRb

    baje los 11 y tampoco

    no se que pex..😦 pero bueno espero me puedas ayudar

    saludos!!!

    • eLinux / Feb 18 2012 1:15 PM

      Correlo como super-usuario, es decir sudo amd-driver-installer-12-1-x86.x86_64.run

      • manoloss / Feb 18 2012 2:49 PM

        asi lo corro

        sudo sh amd-driver-installer-12-1-x86.x86_64.run

        intente por medio de los repositorios privativos y al parecer si lo instalo

        verifique la info de glxinfo y en rendering o algo asi marca como YES

        en ubuntu eso significaba que estaba activada la aceleracion 3D (me imagino que aqui tambien)

        pero al activar efectos de escritorio me marca:

        no se pudieron activar los efectos de escritorio : (y una lista de todos los efectos)😦

        tengo una placa HD5770
        e instale Fedora 16 X64 KDE (por que lei que gnome no era compatible con ATI asi que meti KDE)

        espero me puedan ayudar

        y tambien si me pueden dar algun tip para los codec H264 (HD) para ver videos Full HD en mi television que ese fue el gran coco que tuve en ubuntu y que en windows me corren al full

        muchas gracias y saludos..!!!

        • Gómez Hyuuga / Feb 18 2012 4:31 PM

          Prueba lo siguiente:
          1) Marca el checkbox de Activar Efectos de escritorio pero no le des a aplicar
          2) Haz clic en la pestaña Avanzado
          3) Cambia OpenGL por XRender
          4) Aplica los cambios (pulsa el botón Aplicar)
          5) Si se activaron los efectos, entonces ya cambia de nuevo XRender por OpenGL y aplica cambios a ver si te deja.

          • manoloss / Feb 18 2012 8:20 PM

            Gracias amigo hice lo que me dijiste y al regresar a openGL me marca el siguiente error

            Los efectos de escritorio no están disponibles en este sistema debido a los siguientes problemas técnicos:

            La composición OpenGL (la predeterminada) ya ha hecho fallar KWin con anterioridad.
            Esto fue debido posiblemente a un error en un controlador.
            Si cree que se ha actualizado a un controlador estable,
            puede reiniciar esta protección pero ¡tenga en cuenta que puede provocar un fallo inmediatamente!

            Como alternativa, puede utilizar el motor XRender.

            k sera k pasa?? fijate que hace rato ejecute el glxgears y me marca 60 fps…

            eso es una broma?? mi tarjeta seguramente debe de aguantar mucho mas.. vi un post donde uno con la 4760 tenia casi 9000 de fps

            mi procesador es AMD X6 1090T asi que ese no creo que tampoco sea problema
            con 8 gb de ram

            bueno saludos.. y seguimos en contacto…

            gracias

  15. toro / Mar 18 2012 11:09 PM

    ola amigo me muetralos siguiente erros espero puedaas ayudarme de antemano gracias

    ninstalling any previously installed drivers.
    Unloading radeon module…
    Unloading drm module…
    ERROR: Module drm is in use by ttm,drm_kms_helper
    [Message] Kernel Module : Trying to install a precompiled kernel module.
    [Message] Kernel Module : Precompiled kernel module version mismatched.
    [Message] Kernel Module : Found kernel module build environment, generating kernel module now.
    AMD kernel module generator version 2.1
    doing Makefile based build for kernel 2.6.x and higher
    rm -rf *.c *.h *.o *.ko *.a .??* *.symvers
    make -C /lib/modules/3.2.10-3.fc16.x86_64/build SUBDIRS=/lib/modules/fglrx/build_mod/2.6.x modules
    make[1]: se ingresa al directorio `/usr/src/kernels/3.2.10-3.fc16.x86_64′
    CC [M] /lib/modules/fglrx/build_mod/2.6.x/firegl_public.o
    CC [M] /lib/modules/fglrx/build_mod/2.6.x/kcl_acpi.o
    In file included from /usr/src/kernels/3.2.10-3.fc16.x86_64/arch/x86/include/asm/uaccess.h:575:0,
    from include/asm-generic/termios.h:51,
    from /usr/src/kernels/3.2.10-3.fc16.x86_64/arch/x86/include/asm/termios.h:1,
    from include/linux/termios.h:5,
    from include/linux/tty.h:41,
    from include/linux/vt_kern.h:11,
    from /lib/modules/fglrx/build_mod/2.6.x/kcl_acpi.c:35:
    /usr/src/kernels/3.2.10-3.fc16.x86_64/arch/x86/include/asm/uaccess_64.h: En la función ‘copy_from_user’:
    /usr/src/kernels/3.2.10-3.fc16.x86_64/arch/x86/include/asm/uaccess_64.h:57:7: error: el objeto ‘2’ llamado no es una función
    make[2]: *** [/lib/modules/fglrx/build_mod/2.6.x/kcl_acpi.o] Error 1
    make[1]: *** [_module_/lib/modules/fglrx/build_mod/2.6.x] Error 2
    make[1]: se sale del directorio `/usr/src/kernels/3.2.10-3.fc16.x86_64′
    make: *** [kmod_build] Error 2
    build failed with return value 2
    [Error] Kernel Module : Failed to compile kernel module – please consult readme.
    [Reboot] Kernel Module : dracut

Comparte tu opinión

Introduce tus datos o haz clic en un icono para iniciar sesión:

Logo de WordPress.com

Estás comentando usando tu cuenta de WordPress.com. Cerrar sesión / Cambiar )

Imagen de Twitter

Estás comentando usando tu cuenta de Twitter. Cerrar sesión / Cambiar )

Foto de Facebook

Estás comentando usando tu cuenta de Facebook. Cerrar sesión / Cambiar )

Google+ photo

Estás comentando usando tu cuenta de Google+. Cerrar sesión / Cambiar )

Conectando a %s